Tapeheads Tape, Audio and Music Forums
High quality analog audio tape for professionals and enthusiasts alike.

Go Back   Tapeheads Tape, Audio and Music Forums > Tape, Taping and Tape Machines > Cassette

Cassette All discussions pertaining to cassette decks. These include general usage, recording, playback and service questions. For subjects related to tape itself, see the Cassette Tape subforum under this one. Obscure service subjects that don't quite fit go in the Help and Do It Yourself subforum.

Donate to Tapeheads!
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-19-2017, 07:33 AM
hipacky hipacky is offline
Serious Tapehead
 
Join Date: Jul 2016
Posts: 115
Frustrated Dragon Power Supply Problem - Please help!

Hi all,

So, my Dragon started acting up yeterday and I found that the Auto Azimuth belt had to be replaced. Replacing the belt wasnt too hard, but after I had the unit back together, I plugged it in and... nothing. The counter lights up and thats all.

So I started investigating if I accidentally disconnected something... and I noticed that I smashed pin 1 of CN-34 a against the chassis, causing a short! Oh no...

I obviously fixed the short, but +12V on CN-34 and -12V on CN-10 are dead.
I measured resistance on the +12V pin of CN-34 and it shows a 70 Ohms resistance to ground, which I also think is too low. Not sure what is causing this.

I tested Q402 and it measures fine. Im not very familiar with the Dragon electronics so I have no idea what to look for and where. All I know is that this accidental short made something fail. Fuses are OK.

Im so sad right now, what was a simple belt change now made my Dragon an expensive paperweight!

I appreciate any input.
 


Would you like to see your company or site here?  CONTACT US
For more Tapeheads affiliates and links, see the Links and Resources page.


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Grundig power supply problem stushug Receivers, Amps, and Preamps - Solid-State 19 03-03-2017 09:22 PM
Revox A77 power supply board connection problem powerdoc Reel To Reel 2 03-15-2016 02:13 PM
Revox B77 Power Supply Problem/Previous Owner Modded Alan P Reel To Reel 3 12-30-2013 09:22 AM
Teac A-3440 power supply problem Crawford Tillinghast Reel To Reel 10 09-11-2012 04:11 PM
Crown Pre, power, switcher, power supply Mark J Complete Systems 10 07-24-2010 05:48 PM


All times are GMT -7. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2016, Tapeheads.Net. All rights reserved, no use of any element incorporated into this site without express written permission.